Get in touch
Back
Maintenance

Scheduled maintenance

Completed 24 Aug at 11:59pm CEST.

Akpa Production
Completed

Maintenance completed

Posted 24 Aug at 11:59pm CEST.
Started

Adding splitting of products based on their location to the order picking module.

Posted 24 Aug at 11:50pm CEST.