Get in touch
Back
Maintenance

Software update

Completed 19 Jul at 08:00pm CEST.

Akpa Production
Completed

Maintenance completed

Posted 19 Jul at 08:00pm CEST.
Started

We're updating the software to apply new functionality and stability improvements.

Posted 19 Jul at 07:56pm CEST.